
Animation Basics
 
 
Learning Objectives
After completing this chapter, you will be able to:
• Work with the time slider
• Understand animation playback controls
• Understand animation and time controls
• Morph compound object
• Render and preview an animation
• Understand rendering effects

INTRODUCTION
In 3ds Max, you can create different types of animation. You can create character animation and
animation based on different types of motions that you see in real life. You can also create special
lighting effects in the scene by animating lights and cameras.
 
The basic concept of computer animation is to define different positions, rotations, and scale of an
object at different key points in a sequence in the time slider. These defined points are known as
keyframes. The interpolation between the keyframes consists of the information of the actions
performed between those keyframes. When you play the animation, the computer plays a series of
frames quickly and the object seems to be moving. In 3ds Max, the standard frame rate is 30 frames
per second. It means, if you want to create an animation for one minute, then you need to adjust about
1,800 frames. Therefore, before starting an animation, you need to calculate the frames according to
the time limit.
 
TIME SLIDER AND ANIMATION PLAYBACK CONTROLS
3ds Max provides various options to animate objects that you create in it. To do so, you need to be
familiar with the animation playback controls and time slider. These controls enable you to play,
pause, and stop an animation. They are available at the lower right corner of the 3ds Max interface
and are discussed here briefly.

 
Time Slider
The time slider displays the current frame and the total number of frames in the
current time segment, refer to Figure 14-1. You can view the animation at each frame
by dragging the time slider.



Figure 14-1 The time slider
 

Note
The time segment is the total range of frames that you can access using the time slider. By default,
it ranges from 0 to 100. You can set the range using the Time Configuration dialog box. You will
learn about this dialog box in the later section.
 
Animation Playback Controls
The animation playback controls are used to play and stop the animation in the active viewport. These
controls are discussed next.
 

The Play Animation button is used to play or start the animation in the active viewport. When you
click on the Play Animation button, it turns into a stop button.
 

The Stop Animation button is used to stop the animation. This button is displayed when you play
the animation.
 

The Go to Start button is used to set the time slider at the first frame of the active time segment.
 

The Go to End button is used to set the time slider at the last frame of the active time segment.

The Previous Frame button is used to move the time slider one frame at a time in the reverse
direction. You can view the current frame on the time slider when it moves from one frame to another.
 

The Next Frame button is used to move the time slider one frame at a time in the forward
direction.
 
 
UNDERSTANDING ANIMATION AND TIME CONTROLS
In 3ds Max, different types of tools are available at the bottom of the screen to control animation and
its time settings, refer to Figure 14-2. You have already learned about the time slider and the
animation playback controls in the previous section. The other controls are discussed next.

Figure 14-2 The time control tools
 

Toggle Auto Key Mode
The Toggle Auto Key Mode button that is labeled as Auto Key is used to turn on the auto key



animation mode. When you choose the Toggle Auto Key Mode button, it turns red. Also, the
background of the time slider and the border of the active viewport turns red, indicating that you are
in the animation mode. Now, if you make any changes in the object, the changes will be keyframed in
the time slider.
 
To perform an animation using the Toggle Auto Key Mode button, first you need to make sure that the
object that you want to animate is selected in the viewport. Choose the Go to Start button to set the
time slider to the first frame. Next, choose the Toggle Auto Key Mode button to turn on the auto key
animation mode; it will turn red. Now, drag the time slider to a frame other than 0 and animate the
selected object by modifying its parameters or by transforming the object; a keyframe will be created
on that frame and at frame 0 on the track bar below the time slider. Again, move the time slider to
another frame and change the parameters. You can continue this process until you get all the keyframes
in a sequential order for your animation. Next, choose the Toggle Auto Key Mode button again to
turn it off. Choose the Play Animation button to view the animation of the selected object in the
current viewport.

Toggle Set Key Mode
The Toggle Set Key Mode button that is labeled as Set Key is used to turn on the set key animation
mode. In this mode, you need to set keys for the animation of the selected object by choosing the Set
Keys button on the left side of the Toggle Set Key Mode button.

To perform an animation using the Toggle Set Key Mode button, select the object in the viewport that
you want to animate. Choose the Go to Start button to set the time slider to the first frame. Next,
choose the Toggle Set Key Mode button to turn on the set key animation mode; the button will turn
red. Choose the Set Keys button; it will flash in red color and a keyframe will be set for the current
position of the selected object. Now, drag the time slider to set a frame other than 0 and animate the
selected object. Again, choose the Set Keys button; it will flash in red color and another keyframe
will be set on the track bar for the changed position. You can continue this process until you get all the
keyframes in a sequential order for your animation. Then, choose the Toggle Set Key Mode button to
turn it off. Also, choose the Play Animation button to view the animation of the selected object in the
current viewport.
 

Note
If you transform an object when the Toggle Set Key Mode button is chosen, then the keyframe will
be set only when you choose the Set Keys button.
 
Current Frame (Go To Frame)
The value in this spinner shows the current frame number at which the time slider is positioned.
While animating your scene, if you want to go to another frame, you can enter the frame number
directly in the Current Frame (Go To Frame) spinner. As you drag the time slider, the value in the
Current Frame (Go To Frame) spinner will change automatically according to its position.
 



Key Mode Toggle
By default, the Key Mode Toggle button is not activated. If activated, it allows you to jump between
the keyframes directly. To understand the function of this button, you need to select the animated
object in the viewport. Next, choose the Key Mode Toggle button; the Previous Frame and Next
Frame buttons in the animation playback controls will be replaced with the Previous Key and Next
Key buttons, refer to Figures 14-3 and 14-4. Choose the Previous Key or Next Key button to move
the time slider from one keyframe to the other.

Figure 14-3 Animation playback controls before choosing the Key Mode Toggle button

Figure 14-4 Animation playback controls after choosing the Key Mode Toggle button
 
Time Configuration
The Time Configuration button is used to set the length of an animation by defining the number of
frames in the track bar. It is also used to set the frame rate, time display, and so on. To set these
parameters, choose the Time Configuration button; the Time Configuration dialog box will be
displayed, as shown in Figure 14-5. You need to use the options in this dialog box to set the animation
length, frame rate, and time display. The options in this dialog box are discussed next.

Frame Rate Area
There are four radio buttons in this area, namely NTSC, Film, PAL, and Custom. These radio buttons
are used to define a particular frame rate for the animation in frames per second. By
default, the NTSC radio button is selected. On selecting the Custom radio button,the FPS spinner is
activated wherein you can specify the frame rate in seconds for the animation.

Figure 14-5 The Time Configuration dialog box

 
Time Display Area



The radio buttons in this area are used to define the method of time displayed in the time slider. The
radio buttons in this area are Frames, SMPTE, FRAME: TICKS, and MM:SS: TICKS. By default,
the Frames radio button is selected.
 
Playback Area
This area is used to specify the playback speed and the viewport that will be playing the animation.
By default, the Real Time check box in this area is selected. As a result, animation is played at the
selected playback speed and frames are skipped so that the animation synchronizes with the current
frame rate settings. You can select one of the radio buttons such as 1/4x, 1/2x, and so on in the Speed
group to define the speed of the animation. If you clear the Real Time check box, then the Speed
group will be deactivated and the Direction group will be activated. The radio buttons in the
Direction group are used to define the direction of the animation. The direction of the animation can
be forward, reverse, or ping-pong. The ping-pong direction means that first the animation will be
played in the forward direction and then in the reverse direction. The Active Viewport Only check
box is selected by default and is used to play the animation only in the active viewport. If you clear
this check box, then the animation will be simultaneously played in all the viewports. The Loop check
box is also selected by default and is used to play the animation repeatedly.
 
Animation Area
The options in this area are used to set the length of animation. The default values in the spinners of
this area specify the number of frames for the animation. The Start Time and End Time spinners are
used to specify the current time segment in the time slider. The current time segment is the total range
of frames that you can access using the time slider. The Length spinner is used to specify the total
number of frames in the current time segment or the length of the animation. The Frame Count spinner
is used to specify the number of frames that will be rendered. The Current Time spinner is used to
specify the current frame number at which the time slider is positioned. If you choose the Re-scale
Time button, the Re-scale Time dialog box will be displayed. You can specify the options in this
dialog box to change the existing time segment to a new time segment.
 
Track Bar
The track bar lies between the time slider and the status bar. It shows a timeline with the frame
numbers in it, as shown in Figure 14-6.

Figure 14-6 Partial view of the track bar
 

Track View
Menu bar: Graph Editors > Track View - Curve Editor
Graph Editors > Track View - Dope Sheet
Main Toolbar: Curve Editor (Open)

The track view is used to control the animation keys in the animation created by you. You can also
insert sound in the scene and create notes of it. The track view uses two different modes, Curve



Editor and Dope Sheet. In the Curve Editor mode, the animation is displayed as the function curve
on a graph, refer to Figure 14-7. In the Dope Sheet mode, the animation is displayed as a spreadsheet
of keys, refer to Figure 14-8.

 
To edit the animation of an object using Curve Editor, select the animated object and choose the
Curve Editor (Open) tool from the Main Toolbar; the Track View - Curve Editor window will be
displayed, refer to Figure 14-7. The pull-down menus on the top of this window are used to choose
different options to edit the animation. The hierarchy on the left side of this window is used to display
all the objects of the scene. To view the sub-options in this tree, you need to click on the plus sign (+).
The edit window on the right of the hierarchy tree is used to edit the animation of the objects using the
tangent handles available on the keys found on the curves.

Figure 14-7 The Track View - Curve Editor window
 

To edit the animation of an object using Dope Sheet, select the animated object and choose Graph
Editors > Track View - Dope Sheet from the menu bar; the Track View - Dope Sheet window will
be displayed, refer to Figure 14-8.

Figure 14-8 The Track View - Dope Sheet window
 
In this window, you can view all the keys in a spreadsheet format. You need to select the keys and
edit them according to the animation.
 

Tip: You can also invoke Track View - Curve Editor in place of the track bar. To do so, choose
the Open Mini Curve Editor button on the left side of the track bar.
 
MORPH COMPOUND OBJECT
Menu bar: Create > Compound > Morph
Main Toolbar: Create > Geometry > Compound Objects > Object Type rollout > Morph
The Morph tool is used to create morphing in the objects. The morphing is an animation technique in
which the morph object combines two or more objects by matching their vertices in a sequential form
to produce the animation result. The original object is known as the base object and the other object
into which the base object gets morphed is known as the target object. Note that to perform morphing,
the base and target objects must be mesh, patch, or poly objects and they should have the same



number of vertices.
To create a morph object, first create an object

Figure 14-9 The base and target objects for morphing

and convert it into an editable object. This object will be the base object. Next, create two copies of
the object and modify their shapes by selecting the Vertex sub-object level, as shown in Figure 14-9.
You can also give the shape of your choice to the objects. These objects will be the target objects.
Now, choose the Toggle Auto Key Mode button to turn it on and choose the Go to Start button to
move the time slider to frame 0. Select the base object and choose Create > Compound > Morph
from the menu bar; the Pick Targets and Current Targets rollouts will be displayed in the modify
panel. Next, set the value 35 in the Current Frame (Go To Frame) spinner to move the time slider to
frame 35. In the Pick Targets rollout, choose the Pick Target button and move the cursor over the
first target object; a selection cursor will be displayed. Select the first target object in the viewport.
Similarly, set the value 70 in the Current Frame (Go To Frame) spinner to move the time slider to
frame 70 and select the second target object. When you select the target objects in the viewport, the
names of the base and target objects will be displayed in the Morph Targets area of the Current
Targets rollout. Choose the Toggle Auto Key Mode button again to turn it off. Choose the Play
Animation button to view the animation.
 
RENDERING AN ANIMATION
Menu bar: Rendering > Render Setup
Main Toolbar: Render Setup
Keyboard: F10

Rendering is a process of generating a

Figure 14-10 The Render Setup: Default Scanline Renderer dialog box

2-dimensional image from a 3-dimensional scene. It shows the lighting effects, materials applied,



background, and other settings that you set for the scene. In earlier chapters, you have already learned
about the basic rendering for still images. The advanced rendering used for the animated scene is
discussed next.
 
To render the final animation, choose the Render Setup tool; the Render Setup: Default Scanline
Renderer dialog box will be displayed, as shown in Figure 14-10. The Common tab is chosen by
default in this dialog box. Set the parameters in different rollouts displayed in the Common tab. Also,
in the View drop-down list located at the bottom of this dialog box, select the viewport that you want
to render. Next, choose the Render button; the Perspective, frame 0, Display Gamma:2.2, RGBA
Color 16 Bits/Channel (1:1) dialog box and the Rendering dialog box will be invoked, displaying
the rendering process, refer to Figure 14-11. Various rollouts in the Render Setup: Default Scanline
Renderer dialog box are discussed next.

 
Common Parameters Rollout
There are different types of renderers to render the scene in 3ds Max such as NVIDIA mental ray
renderer, VUE File Renderer, and so on. The options in this rollout are used to set the parameters
common for all types of renderers. The commonly used areas in this rollout are discussed next.

Figure 14-11 The Rendering dialog box
 

Time Output Area
This area is used to set the number of frames that you want to render. By default, the Single radio
button is selected that enables you to render only a single frame. To render the animation, you need to
select the Active Time Segment radio button. This radio button renders all the frames in the current
time segment. Select the Range radio button to specify a range of frames for rendering by entering the
start and end frame numbers in the spinners given on the right of this radio button. The Frames radio
button allows you to render the frame numbers of your choice. To do so, select this radio button and
enter the required frame number in the text box given on the right of this radio button.

Output Size Area
The options in this area are used to define the size of the rendered image. The drop-down list in this
area is used to specify industry-standard film and video aspect ratios. You can choose one of the
formats and then use the remaining group controls to set the output resolution. You can also set the
aspect ratio and resolution of your choice by using the Custom option. Choose one of the default
buttons, 320x240, 640x480, 720x486, or 800x600 to define the size of the output window. When you
choose any of these buttons, the corresponding values will be displayed in the Width and Height
spinners. You can also set the values manually in the Width and Height spinners to define the size.
 



Options Area
The check boxes in this area are used to filter the options to render for the final output such as
atmosphere, lighting effects, and so on.
 
Advanced Lighting Area
The check boxes in this area are used to select options for using advanced lighting and for computing
it on per-frame basis when required.
 
Bitmap Performance and Memory Options Area
This area is used to decide whether 3ds Max will use the full resolutions maps or the proxies of the
maps at rendering. To assign the settings, choose the Setup button in this area; the Global Settings
and Defaults for Bitmap Proxies dialog box will be displayed. You can set the required parameters
in this dialog box.
 
Render Output Area
This area is used to specify a file where the rendered animation can be saved. To do so, choose the
Files button; the Render Output File dialog box will be displayed. Enter the name of the file in the
File name text box and then select the type of file from the Save as type drop-down list. Next,
choose the Save button. If you have selected AVI File (*.avi) file type, the AVI File Compression
Setup dialog box will be displayed. Use the default settings and choose the OK button; the Save File
check box will get selected and the path of the file will be displayed just below the Files button in the
Render Output area.
 
Assign Renderer Rollout
This rollout is used to set renderer for the scene. The Production option is used to assign a renderer
for the graphics. The Material Editor option is used to assign a renderer for the sample slots in the
Material Editor dialog box. The ActiveShade option is used to assign a renderer for the lighting
effects in the scene, refer to Figure 14-12.
 
To assign the renderer, choose the Choose Renderer button on the right of the options given in this
rollout; the Choose Renderer dialog box will be displayed, as shown in Figure 14-13. Select the
renderer and choose the OK button; the name of the selected renderer will be displayed in the text
box on the right of the selected option. Choose the Save as Defaults button in the Assign Renderer
rollout to save the settings as default for further use.
 

Note
If you install any additional renderer plug-ins in 3ds Max, the renderer types will be added to the
Choose Renderer list.
 



Figure 14-12 The Assign Renderer rollout

Figure 14-13 The Choose Renderer dialog box
 
PREVIEWING AN ANIMATION
If a scene has a large number of objects, lights, and special effects, it may take a longer time to render
the final animation and therefore you will not be able to know how the final render would look like.
However, in 3ds Max, you can preview its render. Note that the preview will be in low resolution
and will display the diffuse color maps only. Therefore, it takes lesser time to render. You can have a
look at your animation before the final rendering.
 
To create a preview animation, choose Tools > Preview - Grab Viewport > Create Preview
Animation from the menu bar; the Make Preview dialog box will be displayed, as shown in Figure
14-14. Alternatively, choose Create Preview > Create Preview Animation from the General
viewport label menu to invoke the Make Preview dialog box, refer to Figure 14-15. Set the
parameters for different options in this dialog box and select the viewport that you want to render
from the Render Viewport drop-down list which is located at the bottom of the dialog box. Next,
choose the Create button; the Video Compression dialog box will be displayed. Use the default
settings and choose the OK button; the rendering of the preview will start. Once the preview has been
created, it will automatically start in the Windows Media Player.
 
To view the last preview animation, choose Tools > Preview - Grab Viewport > Play Preview
Animation from the menu bar; the animation will start playing in the Windows Media Player.
Alternatively, choose Create Preview > Play Preview Animation from the General viewport label
menu, refer to Figure 14-15.
 
RENDERING EFFECTS
The Rendering effects are the special effects assigned to a scene. These effects are visible only on
rendering. To assign a rendering effect to a scene, choose Rendering > Effects from the menu bar;
the Environment and Effects dialog box will be displayed, as shown in Figure 14-16. The Effects
tab is chosen by default. In the Effects rollout of this tab, choose the Add button; the Add Effect
dialog box will be displayed, as shown in Figure 14-17. Select the rendering effect from the list given
in this dialog box and choose the OK button; the selected rendering effect will be displayed in the



Effects text area of the Effects rollout. Also, the rollouts related to the selected effect will be
displayed in the Environment and Effects dialog box. Next, set the parameters for the selected
rendering effect in these rollouts and close the dialog box. Now, render the final scene; the rendering
effects will be displayed in the final rendered image.

Figure 14-14 The Make Preview dialog box

Figure 14-15 The flyout and the cascading menu of the General viewport label

Figure 14-16 The Environment and Effects dialog box

Figure 14-17 The Add Effect dialog box
 

TUTORIALS
Before starting the tutorials, you need to download the c14_3dsmax_2015_tut.zip file from
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds



Max > Autodesk 3ds Max 2015: A Comprehensive Guide
 
Extract the contents of the zipped file and save them in the Documents folder.
Tutorial 1
In this tutorial, you will create a walkthrough in a water tunnel, refer to Figures 14-18 and 14-19.
(Expected time: 60 min)
 

Figure 14-18 Animated scene for tunnel at frame 600

Figure 14-19 Animated scene for tunnel at frame 920
 

The following steps are required to complete this tutorial:
 
a. Create the project folder.
b. Create a tunnel.
c. Create a camera.
d. Create water surface.
e. Create and assign materials to water surface.
f. Create walkthrough.
g. Rescale the active time segment.
h. Create animation in water.
i. Assign environment to the scene.
j. Save and render the scene.
 
Creating the Project Folder
1. Create a new project folder with the name c14_tut1 at \Documents\3dsmax2015 and then save the

file with the name c14tut1, as discussed in Tutorial 1 of Chapter 2.
 
2. Open the Windows Explorer and then browse to the c12_3dsmax_2015_tut folder. Next, copy the files

tunnel_material.jpg and ice_environment.jpg at the location
\Documents\3dsmax2015\c14_tut1\sceneassets\images.



Creating a Tunnel
To create a tunnel, you need to use various splines and the Loft tool from Compound Objects.
 
1. Activate the Front viewport. Choose Create > Shapes in the Command Panel; the Splines option

is displayed by default in the drop-down list below the Shapes button. Choose the Donut tool from
the Object Type rollout.

 
2. Create a donut in the Front viewport. It is automatically named as Donut001. Now, set its

parameters in the Parameters rollout as follows:
 
Radius 1: 720.539 Radius 2: 848.293
 
3. In the Interpolation rollout, set the value 20 in the Steps spinner.
 
4. Choose the Zoom Extents All tool to view Donut001 in viewports properly.
 
5. Activate the Top viewport. Choose the Zoom tool and zoom out the viewport so that Donut001 is

visible to half of its original size.

6. Choose the Line tool from Create > Shapes > Splines > Object Type rollout in the Command
Panel. In the Creation Method rollout, select the Smooth and Corner radio buttons in the Initial
Type and Drag Type areas, respectively.

 
7. Create a line in the Top viewport, as shown in Figure 14-20. It is automatically named as Line001.
 
Next, you need to create a loft compound object.
 
8. Make sure Line001 is selected in the Top viewport. Choose Create > Geometry in the Command

Panel; the Standard Primitives option is displayed by default in the drop-down list below the
Geometry button. Select the Compound Objects option from the drop-down list and choose the
Loft tool from the Object Type rollout.

 
9. In the Creation Method rollout of the Loft tool, choose the Get Shape button and move the cursor

over Donut001 in the Front viewport; the shape of the cursor changes, as shown in Figure 14-21.
Click on Donut001; the shape of a tunnel is created in the viewports. Right-click to exit the loft
command. Choose the Zoom Extents All tool to view the entire shape in the viewports, as shown
in Figure 14-22.

 

Note
If the shape displayed after performing the loft command is not similar to the tunnel, you need to
modify the placement of vertices of Line001 spline at the Vertex sub-object level.



 
10. The lofted object is automatically named as Loft001. Modify its name to water tunnel.
 

Figure 14-20 A line created for the tunnel

Figure 14-21 The cursor displayed after moving it over Donut001
 

Figure 14-22 The shape of the tunnel created in the viewports using the Loft tool
 
Creating a Camera
In this section, you will create a walkthrough inside water tunnel by using the Target camera tool.
 
1. Activate the Front viewport. Choose Create > Cameras in the Command Panel and then choose

the Target tool from the Object Type rollout.
 
2. In the Front viewport, create a target camera and align it in all the viewports using the Select and

Move and Select and Rotate tools, refer to Figure 14-23. It is automatically named as
Camera001.



Figure 14-23 Alignment of Camera001 in viewports

Note
While aligning the target camera, make sure that the target of the camera is also selected along
with Camera001.
 
3. Activate the Perspective viewport and press the C key to switch to the Camera001 viewport; the

camera view is displayed, refer to Figure 14-23. Also, choose the Shaded option from the Shading
viewport label menu of the Camera 001 viewport.

 
Creating the Water Surface
In this section, you will create water surface by using the Plane tool.
 
1. Choose the Plane tool from Standard Primitives in the Command Panel. Create a plane in the

Top viewport.
 
2. In the Parameters rollout, set the values in the Length and Width spinners so that the plane covers

the area around the tunnel, refer to Figure 14-24. Also, set the values in the Length Segs and
Width Segs spinners to 30.

 
3. Name the plane in the Name and Color rollout as water surface and align it in the viewports, refer

to Figure 14-24.
 
Next, you need to create and assign materials to water tunnel and water surface.
 



Figure 14-24 The water surface created and aligned in viewports
 
Creating and Assigning Materials to Water Surface
In this section, you will create materials for water surface.
 
1. Make sure water surface is selected in any viewport and then choose Rendering > Material

Editor > Compact Material Editor from the menu bar; the Material Editor dialog box is
displayed.

2. Select the 01-Default sample slot, if it is not already been selected and then modify the name of the
material in the Material Name drop-down list to water surface material.

 
3. Choose the Material Type button that is currently labeled as Standard; the Material/Map

Browser dialog box is displayed. Select the Raytrace material from Materials > Standard and
choose the OK button; the Standard material is replaced by the Raytrace material.

 
Make sure in the Raytrace Basic Parameters rollout, the Phong shader is selected in the Shading

drop-down list.
 
4. Choose the Diffuse color swatch; the Color Selector: Diffuse dialog box is displayed. Set the

following values and then choose the OK button.
 
Red: 136 Green: 210 Blue: 213
 
5. Choose the Reflect color swatch; the Color Selector: Reflect dialog box is displayed. Set the

following values and then choose the OK button.
 
Red: 240 Green: 240 Blue: 240
6. Choose the Reflect map button on the right of the Reflect color swatch; the Material/Map

Browser dialog box is displayed. Select the Falloff map from the Maps > Standard rollout and
choose the OK button; the Falloff map is displayed as sub-material. Use the default settings and
choose the Go to Parent button to go back to the parent level.

 

Note
You can assign a map using the Reflect map button in the Raytrace Basic Parameters rollout or
using the Reflect map button in the Maps rollout.
 
7. Select the Bump check box in the Raytrace Basic Parameters rollout. Next, choose the button on

the right of the Bump spinner that is labeled as None; the Material/Map Browser dialog box is
displayed. Select the Noise map and choose the OK button; the Noise map is displayed as sub-
material.

 
8. In the Noise Parameters rollout, select the Fractal radio button and set the following parameters:



Size: 30.0 Low: 1.0
 
9. Choose the Go to Parent button to go back to the parent level. Alternatively, you can select the

water surface material option from the Material Name drop-down list.
 
10. Make sure that water surface is selected in the viewport, and then choose the Assign Material to

Selection button; the water surface material is assigned to water surface in the viewport.
 
Next, you need to create material for water tunnel to make it look more realistic.
 
11. Select the 02-Default sample slot and modify its name in the Material Name drop-down list to

water tunnel material.
 
12. In the Shader Basic Parameters rollout, make sure that the Blinn shader is selected in the drop-

down list.
 
Next, you need to assign a map to the selected sample slot.
 
13. In the Blinn Basic Parameters rollout, choose the Diffuse map button on the right of the Diffuse

color swatch; the Material/Map Browser dialog box is displayed. Select the Bitmap map and
choose the OK button; the Select Bitmap Image File dialog box is displayed. As the project folder
is already set, the images folder is displayed in the Look in drop-down list of this dialog box.
Select the file tunnel_material.jpg from this folder and choose the Open button; the selected image
is displayed in the sample slot.

 
14. Choose the Go to Parent button. Expand the Maps rollout and then select the Bump check box to

make it available for material. Choose the Bump map button that is labeled as None; the
Material/Map Browser dialog box is displayed. Select the Bitmap map and choose the OK
button; the Select Bitmap Image File dialog box is displayed. Browse to the same image
(tunnel_material.jpg) that you used for the Diffuse map and choose the Open button; various
rollouts are displayed to modify the coordinates of the map.

15. In the Coordinates rollout, set the value to 4 in the U Tiling and V Tiling spinners. Next, choose
the Go to Parent button to go back to the parent level; the name of the selected image is displayed
over the Bump map button.

 
16. In the Bump spinner, set the value to 100.
 
17. Make sure that water tunnel is selected in the viewport, and then choose the Assign Material to

Selection button; the water tunnel material is assigned to water tunnel in the viewport.
 
18. Close the Material Editor dialog box.
 
19. Activate the Camera001 viewport and choose the Render Production tool to view the maps and



materials assigned to the objects. The scene is displayed, as shown in Figure 14-25.
 
Creating Walkthrough
In this section, you will create a walkthrough.
 
1. Activate the Top viewport and choose the Maximize Viewport Toggle tool to maximize it.
 
2. Create a line from the lower left side to the upper right side of the viewport according to the shape

of the water tunnel, as shown in Figure 14-26. Alternatively, you can also use the Line001 spline
created earlier to loft the tunnel.

Figure 14-25 The scene after assigning the materials

Figure 14-26 A line created for the path
 

3. Modify the name of the line as path and align it in the viewports, as shown in Figure 14-27. Next,
choose the Maximize Viewport Toggle tool.

Figure 14-27 The path aligned in viewports
 

Next, you need to increase the number of frames in the track bar to create a smooth animation.
 
4. Choose the Time Configuration button at the bottom of the screen; the Time Configuration dialog

box is displayed. In the Animation area of this dialog box, set the value 1000 in the End Time
spinner and press the ENTER key; the number of frames increases in the track bar. Choose the OK



button to exit the dialog box.
Next, you need to move Camera001 along with path.
 
5. Select Camera001 in any viewport and choose the Motion tab in the Command Panel. By default,

the Parameters tab is chosen in this panel.
 
6. Expand the Assign Controller rollout in the Parameters tab and then choose the Position :

Position XYZ option from it; the Assign Controller button is activated, as shown in Figure 14-28.
 
7. Choose the Assign Controller button; the Assign Position Controller dialog box is displayed.

Choose the Path Constraint option and then choose the OK button to exit the dialog box; various
rollouts are displayed below the Assign Controller rollout.

8. In the Path Parameters rollout, choose the Add Path button, refer to Figure 14-29. Next, select
path from the Scene Explorer. Also, Camera001 is moved along with path in the viewport. Right-
click to exit the command.

 

Figure 14-28 The Assign Controller rollout

Figure 14-29 Partial view of the Path Parameters rollout
 

9. Activate the Top viewport and choose the Play Animation button from the time controls area; you
will notice that Camera001 moves along with path but the movement is not proper. To create a
proper movement, you need to adjust the target of Camera001 at different frames.

 
10. Choose the Go to Start button to drag the time slider to frame 0. Next, choose the Toggle Auto

Key Mode button to turn on the animation mode.
 
11. Select Camera001.Target from the Scene Explorer.



12. In the Top viewport, position Camera001.Target using the Select and Move tool, as shown in
Figure 14-30.

 

Note
While aligning the Camera001.Target, you need to view Camera001 viewport simultaneously to
make sure that the animation is proper.
 
13. Drag the time slider to frame 153 and move Camera001.Target along the path, as shown in Figure

14-31. To move the time slider to a particular frame, you can also enter the frame number in the
Current Frame (Go to frame) spinner.

 
14. Move the time slider to frame 300 by entering the frame number in the Current Frame (Go to

frame) spinner. Then, align Camera001.Target, as shown in Figure 14-32.
15. Move the time slider to frame 429 by entering the frame number in the Current Frame (Go to

frame) spinner. Now, align Camera001.Target with path, as shown in Figure 14-33.

Figure 14-30 The position of the Camera001.Target at frame 0

Figure 14-31 The position of the Camera001.Target at frame 153
 

Figure 14-32 The position of the Camera001.Target at frame 300

Figure 14-33 The position of the Camera001.Target at frame 429
 

16. Move the time slider to frame 581 and align Camera001.Target, as shown in Figure 14-34.



 
17. Move the time slider to frame 700 and align Camera001.Target, as shown in Figure 14-35.

Figure 14-34 The position of the Camera001.Target at frame 581

Figure 14-35 The position of the Camera001.Target at frame 700
 

18. Move the time slider to frame 801 and align Camera001.Target, as shown in Figure 14-36.
 
19. Move the time slider to frame 935 and align Camera001.Target, as shown in Figure 14-37.
 

 

Figure 14-36 The position of the Camera001.Target at frame 801

Figure 14-37 The position of the Camera001.Target at frame 935
 

20. Move the time slider to frame 1000 and align Camera001.Target, as shown in Figure 14-38. After
creating the frame-by-frame animation, the frames are displayed in the track bar, as shown in Figure
14-39.

Figure 14-38 The position of the Camera001.Target at frame 1000
 



Figure 14-39 The track bar after creating the animation
 
21. Choose the Toggle Auto Key Mode button to turn off the animation mode and activate

Camera001 viewport. Next, choose the Play Animation button; Camera001 starts moving along
path inside the tunnel.

 

Note
You can also use your own dimensions to align Camera001.Target at different frames.
 
Rescaling the Active Time Segment
While playing animation, if you feel that the pace of animation is very fast, you can increase the
number of frames in the active time segment to make it slow and smooth.
 
1. Choose the Time Configuration button at the bottom of the 3ds Max screen; the Time

Configuration dialog box is displayed. In the Animation area of this dialog box, choose the Re-
scale Time button; the Re-scale Time dialog box is displayed.

2. In the New area, set a new value in the End Time spinner and choose the OK button to exit the
dialog box; the active time segment and animation keys are adjusted accordingly. Choose the OK
button in the Time Configuration dialog box to close it.

 
Creating Animation in Water
In this section, you will create animated waves on the water surface by using the Compact Material
Editor tool.
 
1. Choose the Compact Material Editor tool from the Main Toolbar; the Material Editor dialog

box is displayed.
 
2. Select the water surface material sample slot. Now, in the Raytrace Basic Parameters rollout,

choose the Bump map button that is labeled as Map# X (Noise); various rollouts are displayed for
the Noise modifier.

 
Next, you need to set the keys on the parameters of the Noise modifier to animate water surface.
 
3. Choose the Go to Start button to drag the time slider to frame 0. Next, choose the Toggle Auto

Key Mode button to turn on the animation mode; the selected sample slot is surrounded by a red
border, which indicates that the animation mode is active.

 
4. In the Noise Parameters rollout, make sure that the value in the Phase spinner is 0.0 at frame 0.

Next, choose the Go to End button to move the time slider to the end frame, and then set the value
7.0 in the Phase spinner and then press ENTER; the color of the border of arrows of the spinner
turns red.



 
5. Choose the Toggle Auto Key Mode button to turn off the animation mode and close the Material

Editor dialog box.
 
Assigning Environment to the Scene
In this section, you will create environment to the scene.
 
1. Choose Rendering > Environment from the menu bar; the Environment and Effects dialog box is

displayed.
 
2. The Environment tab is chosen by default. In the Background area of the Common Parameters

rollout, choose the Environment Map button that is labeled as None; the Material/Map Browser
dialog box is displayed.

 
3. Select the Bitmap map and choose the OK button; the Select Bitmap Image File dialog box is

displayed. Select ice_environment.jpg image and choose the Open button; the selected image is
displayed as background after rendering. Close the Environment and Effects dialog box.

 
Note that when Camera001 moves toward the end frames, then only the background of the scene is

displayed in the animation.

Saving and Rendering the Scene
In this section, you will save the scene and then render it. You can also view the final rendered image
sequence by downloading the file c14_3dsmax_2015_rndr.zip from www.cadcim.com. The path of
the file is as follows: Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max
2015: A Comprehensive Guide
 
1. Choose the Render Setup tool from the Main Toolbar; the Render Setup: Default Scanline

Renderer dialog box is displayed. In this dialog box, the Common tab is chosen by default. Also,
various rollouts are displayed in the Common tab.

 
2. In the Common Parameters rollout, select the Active Time Segment radio button in the Time

Output area.
 
3. In the Output Size area, choose the 640x480 button.
 
4. In the Render Output area, choose the Files button; the Render Output File dialog box is

displayed. Enter a name for the file in the File name text box and then select the AVI File (*.avi)
file type from the Save as type drop-down list and specify the desired location of the file in the
Save in text box. Next, choose the Save button; the AVI File Compression Setup dialog box is
displayed. Use the default settings and choose the OK button to exit the dialog box.

 
5. Choose Save from the Application menu.



 
6. Make sure the Quad 4 - Camera001 option is selected in the View drop-down list at the bottom in

the Render Setup: Default Scanline Renderer dialog box. Next, choose the Render button; both
the Camera001, frame# window and the Rendering dialog box are displayed showing the
rendering process.

 
After the completion of the rendering process, the final output of the animation is saved at the

specified location in the *.AVI format. You can view the final output of the animation by opening the
corresponding *.AVI file.

 
Tutorial 2
In this tutorial, you will create an animated scene that contains light effects and animation of lights
and objects, as shown in Figure 14-40. (Expected time: 60 min)

 
The following steps are required to complete this tutorial:
 
a. Create the project folder.
b. Create the wireframe earth sphere.
c. Create the text.
d. Add camera to the scene.
e. Create the animated space background.
f. Create and animate lights in the scene.
g. Animate the wireframe earth sphere and the text.
h. Save and render the scene.

Figure 14-40 The animated scene
 

Creating the Project Folder
1. Create a new project folder with the name c14_tut2 at \Documents\3dsmax2015 and then save the

file with the name c14tut2, as discussed in Tutorial 1 of Chapter 2.
 
2. Open the Windows Explorer and then browse to the c12_3dsmax_2015_tut folder. Next, copy

EarthMap_colored.jpg and EarthMap_b&w.jpg at the location
\Documents\3dsmax2015\c14_tut2\sceneassets\images.

 
Creating the Wireframe Earth Sphere



In this section, you will create two spheres to create a wireframe earth sphere.
 
1. Choose the Sphere tool from Standard Primitives in the Command Panel and create a sphere in

the Top viewport.
 
2. Modify the name of the sphere to earth sphere. Set the value of the Radius spinner to 58.42 in the

Parameters rollout. Next, right-click to exit the tool.
 
3. Make sure that earth sphere is selected and then choose Edit > Clone from the menu bar; the

Clone Options dialog box is displayed.
 
4. Select the Copy radio button in the Object area and enter wireframe sphere in the Name text box.

Next, choose the OK button to close the dialog box. In the Parameters rollout, set the radius of
wireframe sphere to 58.0 in the Radius spinner.

 
Next, you need to apply maps and material to the earth sphere and the wireframe sphere.
 
5. Select earth sphere in any viewport and choose the Compact Material Editor tool; the Material

Editor dialog box is displayed.

6. Select the 01-Default sample slot if it is not already selected and then modify its name in the
Material Name drop-down list to earth map.

 
7. In the Shader Basic Parameters rollout, make sure that the Blinn shader is selected in the drop-

down list, and then select the 2-Sided check box.
 
Next, you need to assign a map to the shader.
 
8. In the Blinn Basic Parameters rollout, choose the Diffuse map button on the right of the Diffuse

color swatch; the Material/Map Browser dialog box is displayed. Select the Bitmap map and
choose the OK button; the Select Bitmap Image File dialog box is displayed. As the project folder
is already set, the images folder is displayed in the Look in drop-down list of this dialog box.
Select the file EarthMap_colored.jpg and choose the Open button; the selected image is displayed
in the sample slot. Also, various rollouts are displayed to modify the coordinates of the map.

 
9. Choose the Go to Parent button to go back to the parent

Figure 14-41 The earth map in the sample slot



level and then choose the Opacity map button in the Blinn Basic Parameters rollout; the
Material/Map Browser dialog box is displayed. Select the Bitmap map and choose the OK
button; the Select Bitmap Image File dialog box is displayed. Select the EarthMap_b&w.jpg
image and choose the Open button; the selected image is displayed in the sample slot, as shown in
Figure 14-41.

 
10. Choose the Go to Parent button again and make sure earth sphere is selected in the viewport.

Next, choose the Assign Material to Selection button; earth map is assigned to earth sphere in the
viewport.

 
11. Choose the Show Shaded Material in Viewport button to view the assigned map in the viewport.
 
12. Render the Perspective viewport to view the map applied using the Render Production tool, as

shown in Figure 14-42.
 
Next, you need to create material for wireframe sphere.
 
13. Select the 02-Default sample slot and modify its name in the Material Name drop-down list to

wireframe map.
 

14. In the Shader Basic Parameters rollout, make sure that the Blinn shader is selected in the drop-
down list and then select the Wire check box; wireframes are displayed in the sample slot, as
shown in Figure 14-43.

Figure 14-42 The earth map applied to the earth sphere after rendering

Figure 14-43 Wireframes displayed in the sample slot
 

15. In the Blinn Basic Parameters rollout, choose the Diffuse color swatch; the Color Selector:
Diffuse Color dialog box is displayed. Set the values in the Red, Green, and Blue spinners as
given next and choose the OK button to exit the dialog box.

 
Red: 239 Green: 106 Blue: 18



 
16. In the Specular Highlights area, set the value 53 in the Specular Level spinner.
 
17. Select wireframe sphere in the viewport and then choose the Assign Material to Selection

button; the wireframe map is assigned to wireframe sphere in the viewport.
 

18. Choose the Show Shaded Material in Viewport button to view the assigned map in the viewport.
Close the Material Editor dialog box.

 
19. Choose the Zoom Extents All tool to view both the spheres in the viewports.
 
Next, you need to align wireframe sphere with earth sphere.
 
20. Select wireframe sphere in the viewport and choose the Align tool from the Main Toolbar; the

shape of the cursor changes. Next, select earth sphere in the viewport; the Align Selection (earth
sphere) dialog box is displayed.

 
21. In the Align Position (World) area, select the X Position, Y Position, and Z Position check

boxes. Next, select the Pivot Point radio button both in the Current Object and Target Object
areas. Next, choose the OK button to close the dialog box.

 
22. Choose the Zoom Extents All tool; wireframe sphere is aligned with earth sphere in the

viewports, as shown in Figure 14-44.

Figure 14-44 Alignment of the wireframe and the earth sphere in viewports
 

23. Activate the Perspective viewport. Choose the Render Production tool from the Main Toolbar;
the rendered sphere is displayed in the Rendered Frame window, as shown in Figure 14-45.



Figure 14-45 The sphere at rendering

 
24. Select wireframe sphere and earth sphere in the viewport simultaneously and then group them as

wireframe earth sphere.
 

Creating the Text
In this section, you will create the text around the wireframe earth sphere by using the Text tool.
 
1. Choose the Text tool from Create > Shapes > Splines > Object Type rollout in the Command

Panel. In the Parameters rollout, set the values as follows:
 
Select the Arial Italic font type from the drop-down list located on the top of the rollout.
 
Make sure that the left alignment button is chosen.
Size: 30.0
 
Text area
Enter CADCIM Technologies.
 
2. Click in the center of Front viewport; the CADCIM Technologies text is displayed in viewports. It

is automatically named as Text001.

3. Choose the Zoom Extents All tool and align Text001 in the viewports, as shown in Figure 14-46.

Figure 14-46 Alignment of Text001 in viewports
 

Now, you need to apply the Extrude modifier to add depth to the text.
 
4. Make sure that Text001 is selected in the viewport. Choose the Modify tab in the Command Panel.

Next, select the Extrude modifier from the Modifier List drop-down list; the Extrude modifier is
displayed in the modifier stack.

 
5. In the Parameters rollout of the Extrude modifier, set the value 3.0 in the Amount spinner.



 
Next, you need to apply material to Text001.
 
6. Choose the Material Editor tool; the Material Editor dialog box is displayed. Select the 03-

Default sample slot and modify its name in the Material Name drop-down list to text material.
 

7. In the Blinn Basic Parameters rollout, choose the Diffuse color swatch; the Color Selector:
Diffuse Color dialog box is displayed. Set the following values in the Red, Green, and Blue
spinners and then choose the OK button to exit the dialog box.

 
Red: 253 Green: 185 Blue: 2
 
8. Make sure Text001 is selected in the viewport and then choose the Assign Material to Selection

button; the text material is assigned to Text001 in the viewport. Close the Material Editor dialog
box.

Next, you need to apply the Bend modifier to Text001 to bend it around wireframe earth sphere.
 
9. Make sure Text001 is selected in the viewport and then choose the Modify tab in the Command

Panel. Next, select the Bend modifier from the Modifier List drop-down list; the Bend modifier is
displayed in the modifier stack.

 
10. In the Parameters rollout of the Bend modifier, set the values as follows:
 
Bend area
Angle: 237.5
 
Bend Axis area
Select the X radio button.
 
11. Align Text001 in viewports, as shown in Figure 14-47.

Figure 14-47 The Text001 aligned in viewports after applying the Extrude and Bend modifiers
 

Adding Camera to Scene
In this section, you will add camera to the scene.



 
1. Choose the Zoom All tool and zoom out all viewports simultaneously to make a proper room

around wireframe earth sphere.
 
2. Choose the Free tool from Create > Cameras in the Command Panel and click in the Front

viewport; a free camera is displayed in all the viewports and is automatically named as
Camera001.

3. Align Camera001 in viewports to view the front side of the scene and then press the C key in the
Perspective viewport to activate the Camera001 viewport, as shown in Figure 14-48.

Figure 14-48 The Camera001 aligned in viewports
 

Creating Animated Space Background
In this section, you will create background for the scene.
 
1. Choose Rendering > Environment from the menu bar; the Environment and Effects dialog box is

displayed with the Environment tab chosen by default. Also, various rollouts are displayed in the
Environment tab.

 
2. In the Common Parameters rollout, choose the Environment Map button in the Background area;

the Material/Map Browser dialog box is displayed. Select the Noise map from the Maps >
Standard rollout and choose the OK button; the Noise map is displayed on the Environment Map
button and applied as the background.

 
Next, you need to set the parameters of the Noise map.
 
3. Press the M key to invoke the Material Editor dialog box. Select the 04-Default sample slot.
 
4. In the Environment and Effects dialog box, press and hold the cursor over the Environment Map

button and drag it to the 04-Default sample slot in the Material Editor dialog box. Next, release
the left mouse button; the Instance (Copy) Map dialog box is displayed. Make sure the Instance
radio button is selected and choose the OK button; the 04-Default sample slot is displayed, as
shown in Figure 14-49. Also, various rollouts to modify the Noise map are displayed.



 
5. Modify the name of the sample slot in the Material Name drop-down list

to space environment map.

Figure 14-49 The sample slot with the Noise environment

 
Next, you need to modify the parameters of the Noise map.
 
6. In the Noise Parameters rollout, set the values as given below:
 
Select the Fractal radio button in the Noise Type area.
 
Size: 0.2 High: 0.8
Low: 0.7
 
7. Render the Camera001 viewport; the scene is displayed with space environment map, as shown

in Figure 14-50.

Figure 14-50 The scene with the space environment map

 
Next, you need to animate the stars in space environment map.
 
8. Choose the Time Configuration button; the Time Configuration dialog box is displayed. In the

Animation area of this dialog box, set the value 1000 in the End Time spinner and press the
ENTER key; the number of frames in the active time segment increases to 1000. Choose the OK
button to exit the dialog box.

 
9. Choose the Toggle Auto Key Mode button to turn on the animation mode and then make sure the

time slider is at frame 0. In the Noise Parameters rollout of the Material Editor dialog box, make
sure that the value in the Phase spinner is 0.0 at frame 0.

 



10. Choose the Go to End button to move the time slider to frame 1000. In the Noise Parameters
rollout, set the value 7.0 in the Phase spinner. The stars in space environment map appear to be
blinking in the final output at rendering.

 
11. Choose the Toggle Auto Key Mode button to turn off the animation mode and then close the

Material Editor dialog box. Also, close the Environment and Effects dialog box.
 
Creating and Animating Lights in the Scene
To create light in the scene, you need to create omni and spot lights in the scene.
 
1. Choose the Zoom tool and zoom out the Top, Front, and Left viewports to create proper room

around wireframe earth sphere, refer to Figure 14-51.
 
2. Activate the Top viewport and choose the Omni tool from Create > Lights > Standard > Object

Type rollout in the Command Panel. In the Top viewport, click at the center of wireframe earth
sphere; an omni light is displayed in all the viewports. It is automatically named as Omni001.
Right-click to exit the command. Next, align Omni001 light in all the viewports, refer to Figure 14-
52.

Figure 14-51 The wireframe earth sphere zoomed out
 

3. Create four copies of Omni001 light and align all lights, as shown in Figure 14-52.
 

Figure 14-52 Omni lights aligned in viewports
 



Note
If your scene has more lighting effects, then choose the Modify tab in the Command Panel and set
the intensity of omni lights. To do so, you need to modify the value in the Multiplier spinner of the
Intensity/Color/Attenuation rollout.
 
Next, you need to add advance effects to omni lights.
 
4. In the Front viewport, select the omni light that is placed on the left side of wireframe earth

sphere, as shown in Figure 14-53.

Figure 14-53 Omni light selected to add the advance effects
 

5. Choose the Modify tab in the Command Panel and expand the Atmospheres & Effects rollout.
Choose the Add button; the Add Atmosphere or Effect dialog box is displayed. Select the Lens
Effects option and choose the OK button to exit the dialog box; the Lens Effects option is
displayed in the Atmospheres & Effects rollout.

Next, you need to set the parameters for the Lens Effects.
 
6. Select the Lens Effects option in the Atmospheres & Effects rollout and choose the Setup

button; the Environment and Effects dialog box is displayed with the Effects tab chosen. Also,
various rollouts are displayed in this tab.

 
7. In the Lens Effects Parameters rollout, select the Glow option and choose the arrow that is

pointing toward the right; the Glow effect is now available for the omni light at rendering. Also, the
Glow Element rollout is displayed in the Environment and Effects dialog box to modify the
parameters of the Glow effect.

 
8. In the Glow Element rollout, set the values as follows:
 
Size: 6 Intensity: 150.0
 
9. In the Lens Effects Parameters rollout, select Ray and then choose the arrow that is pointing

right; the Ray effect is now available for the omni light at rendering. Also, the Ray Element
rollout is displayed in the Environment and Effects dialog box to modify the parameters of the
Ray effect.

10. In the Ray Element rollout, set the values as follows:
 



Size: 15 Intensity: 10.0 Num: 50
 
Use the default values for other options.
 
11. To animate rays in the scene, choose the Toggle Auto Key Mode button to turn on the animation

mode. Next, choose the Go to Start button to move the time slider to frame 0. In the Ray Element
rollout, make sure that the value in the Angle spinner is 0.0 at frame 0.

 
12. Choose the Go to End button to move the time slider to frame 1000, and set the value in the

Angle spinner to 180.0. The rays appear to be rotating in the final output after rendering.
 
13. Choose the Toggle Auto Key Mode button to turn off the animation mode.
 
14. In the Lens Effects Parameters rollout, select the Ring option and then choose the arrow that is

pointing right; the Ring effect becomes available for the omni light at rendering. Also, the Ring
Element rollout is displayed in the Environment and Effects dialog box to modify the parameters
of the Ring effect.

 
15. In the Ring Element rollout, set the values as follows:
 
Size: 3.0 Intensity: 15.0
 
Use the default values for other options.
 
16. Close the Environment and Effects dialog box and render the Camera001 viewport; the omni

light is displayed, as shown in Figure 14-54.
 

Note
If you are not able to view the Omni Light in your render, move Camera001 so that you can see the
Omni light in your render.
 
17. In the Front viewport, select the omni light that is placed just above wireframe earth sphere.

Align it to the top of wireframe earth sphere, as shown in Figure 14-55. Next, add the Lens
Effects as described above and set the parameters of different effects in the Environment and
Effects dialog box as follows:

 
Glow effect
Size: 3.0 Intensity: 150.0
 
Ray effect
Size: 1 Intensity: 30.0 Num: 10
 
Star effect



Size: 3 Intensity: 20 Width: 1.0

Figure 14-54 The effect of the omni light displayed at rendering

Figure 14-55 The omni light aligned just above the wireframe earth sphere
 
18. To animate the effects of this omni light in the scene, choose the Toggle Auto Key Mode button to

turn on the animation mode. Now, choose the Go to Start button to move the time slider to frame 0.
Also, in the Star Element rollout, make sure that the value in the Angle spinner is 0.0 at frame 0.

 
19. Choose the Go to End button to move the time slider to

Figure 14-56 The omni light with the lens effect on rendering
frame 1000 and set the value in the Angle spinner to 90.0. The stars appear to be rotating in the final

output after rendering.
 
20. Choose the Toggle Auto Key Mode button to turn off the animation mode.
 
After applying the effects, the omni light with the lens effect is displayed after rendering, as shown in

Figure 14-56.
 
Next, you need to add spot lights to the scene.

 
21. Choose the Target Spot tool from Create > Lights > Standard > Object Type rollout in the

Command Panel and then create a spot light in the Front viewport, as shown in Figure 14-57.
Also, create another spot light in the Top viewport, as shown in Figure 14-58.



Figure 14-57 Spot light created in the Front viewport

Figure 14-58 Spot light created in the Top viewport
 
The spotlights are automatically named as Spot001 and Spot002.

Now, you need to modify the parameters of the spot lights.
 
22. Select Spot001 from the Scene Explorer and choose the Modify tab in the Command Panel;

various rollouts are displayed to modify the parameters of the spotlight.
 
23. In the Spotlight Parameters rollout, set the values as follows:
 
Hotspot/Beam: 25.3 Falloff/Field: 30.0
 
24. In the Atmospheres & Effects rollout, add the Volume Light effect, select the Volume Light

option in the rollout, and choose the Setup button; the Environment and Effects dialog box is
displayed. In the Volume area of the Volume Light Parameters rollout, set the value in the
Density spinner to 1.5. Close the Environment and Effects dialog box.

 
25. Render the Camera001 viewport; the scene is displayed, as shown in Figure 14-59.
 
26. In the Advance Effects rollout of the Modify panel, select the Map check box in the Projector

Map area. Then, choose the Projector Map button labeled as None and assign a bitmap image of
your choice to this map to give a more realistic effect to the Volume Light at rendering, refer to
Figure 14-60.

Figure 14-59 The scene at rendering after applying the Volume Light effect in the Spot001 light



Figure 14-60 The scene at rendering after assigning a map to Projector Map
 
27. After rendering, you will notice that the Volume Light is visible up to the infinite distance. To

control the distance of the Volume Light, set the parameters in the Far Attenuation area in the
Intensity/Color/Attenuation rollout as follows:

 
Select the Use and Show check boxes.
 
Start: 10 End: 850

Note
You may need to adjust the values in the Start and

Figure 14-61 The scene displayed at rendering after setting the parameters in the Far
Attenuation area

End spinners as the values may differ depending on the placement of the light in the scene.
 

28. Render the Camera001 viewport; the scene is displayed, as shown in Figure 14-61.
 
29. Select Spot002 in the viewport and choose the Modify tab in the Command Panel; all the

rollouts are displayed to modify the parameters of the selected light.
 
30. In the Spotlight Parameters rollout, set the values as follows:
 
Hotspot/Beam: 5.0 Falloff/Field: 7.0

 
31. Choose the Zoom Extents All tool and align Spot002, Spot002.Target in the viewports, as shown

in Figure 14-62.



Figure 14-62 The Spot002, Spot002.Target light aligned in viewports
Next, you need to animate Spot001.
 
32. Select Spot001 and Spot001.Target from the Scene Explorer. Next, choose the Zoom Extents All

Selected tool to view the selected light properly.
 

33. Choose the Toggle Auto Key Mode button to turn on the animation mode and then choose the Go
to Start button to move the time slider to frame 0.

34. Choose the Go to End button to move the time slider to frame 1000 and choose the Select and
Rotate tool. Next, in the Top viewport, move the cursor over the X-axis and rotate the Spot001 and
Spot001.Target in clockwise direction until the value in the Z spinner becomes -360 in the
coordinate display.

 
35. Choose the Toggle Auto Key Mode button to turn off the animation mode.

 
Animating Wireframe Earth Sphere and Text
In this section, you will animate wireframe earth sphere and Text001 in the opposite directions.
 
1. Activate the Top viewport and select wireframe earth sphere. Next, choose the Zoom Extents All

Selected tool; wireframe earth sphere is zoomed in all the viewports, as shown in Figure 14-63.

Figure 14-63 The wireframe earth sphere zoomed in viewports
 

Note
When you choose a tool from the viewport navigation controls, it does not affect the Camera001



viewport.
 
2. Choose the Toggle Auto Key Mode button to turn on the animation mode and choose the Go to

Start button to move the time slider to frame 0.
 

3. Choose the Go to End button to move the time slider to frame 1000 and then choose the Select and
Rotate tool. In the Top viewport, move the cursor over the X-axis and rotate wireframe earth
sphere in the counterclockwise direction until the value in the Z spinner becomes 360 in the
coordinate display.

 
4. Choose the Toggle Auto Key Mode button to turn off the animation mode.

 
Next, you need to animate Text001 around wireframe earth sphere.
 
5. Select Text001 in the Top viewport and choose the Hierarchy tab in the Command  Panel. In the

Adjust Pivot rollout, choose the Affect Pivot Only button; the pivot point of Text001 is displayed
in the viewport, as shown in Figure 14-64.

 
6. Align the pivot point of Text001 at the center of wireframe earth sphere, as shown in Figure 14-65.

Then, choose the Affects Pivot Only button again to deactivate it.
 
 
 
6. Align the pivot point of the Text001 at the center of the wireframe earth sphere, refer to Figure 14-

65. Then, choose the Affect Pivot Only button again to deactivate it.

Figure 14-64 The pivot point of the Text001 displayed in the Top viewport

Figure 14-65 The pivot point of the Text001 aligned in the Top viewport
 

7. Choose the Select and Rotate tool and rotate Text001 in the Top viewport along the Z-axis until
the value in the Z spinner becomes -180 in the coordinate display. Next, choose the Select and
Move tool and align Text001, as shown in Figure 14-66.

 



8. Activate the Front viewport. Next, right-click on the Select and Rotate tool; the Rotate
Transform Type-In dialog box is displayed. Enter 10 in the Z spinner of the Offset:Screen area
and press the ENTER key; Text001 rotates in the Front viewport, as shown in Figure 14-67.

Figure 14-66 The Text001 rotated in the Top viewport

Figure 14-67 The Text001 rotated in the Front viewport
 
9. Choose the Toggle Auto Key Mode button to turn on the animation mode. Choose the Go to End

button to move the time slider to frame 1000 and make sure that Text001 is selected. Enter -360 in
the Y spinner of the Offset:Screen area of the Rotate Transform Type-In dialog box and press
the ENTER key. Now, close this dialog box.

10. Choose the Toggle Auto Key Mode button to turn off the animation mode and choose the Play
Animation button to view the animation.

 
Saving and Rendering the Scene
 
1. Choose Save from the Application menu.
 
2. To view the final output of the scene that contains all the movements, textures, lights, and

animations, you need to render the scene. To do so, follow the procedure described in Tutorial 1 of
this chapter.

 

Answer the following questions and then compare them to those given at the end of this
chapter:
 
1. Which of the following buttons is used to turn on the animation mode?


